[postgis-users] configure: error: GDAL Python bindings required by raster2pgsql.py loader

Puneet Kishor punk.kish at gmail.com
Tue Oct 18 08:50:54 PDT 2011

On Oct 18, 2011, at 8:28 AM, William Kyngesburye wrote:

> I don't think GDALFPolygonize is the problem, that's just a test for a new feature in development GDAL and it's OK if it fails.  After that should be the "checking for GDAL Python bindings" info.
> ..

Gah! Dunno what I did, but now GDAL Python bindings are discovered, but seems like I have the wrong version of something.

RASTER: Raster support requested
checking for GDAL >= 1.6.0... found
checking for GDALFPolygonize in -lgdal... no
checking for GDAL Python bindings... found
checking for NumPy array support in GDAL Python bindings... RuntimeError: module compiled against API version 6 but this version of numpy is 4
not found
configure: error: GDAL Python bindings with NumPy array support required by raster2pgsql.py loader

I am not sure above what is compiled against API version 6 of what and what is the "this numpy" with version 4. Fwiw

punkish at mumbai ~$/opt/local/bin/python2.7
Python 2.7.2 (default, Sep 13 2011, 14:07:58) 
[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy as np
>>> np.__version__

Puneet Kishor

More information about the postgis-users mailing list