[postgis-users] [XX000] ERROR: AddToPROJ4SRSCache: could not parse proj4 string

Andrew Joseph ap.joseph at live.com
Fri Nov 10 15:33:08 PST 2017

SELECT ST_AsText(ST_Transform(ST_Transform(ST_SetSRID(ST_Point(-97.353287,
31.105862), 4326), 2277),4326)); 

produces "POINT(-97.353287 31.1058619999995)" - so it appears to work

The table srid for both concerete and foreign tables shows as 2277.

Using st_transform(st_setsrid(geom,2277),4326) on the foreign table fails as

I've tried reverting my configuration back as far as possible (2.3.2 breaks
on postgres 10+):

"POSTGIS="2.3.4 r16009" GEOS="3.6.2-CAPI-1.10.2 4d2925d6" SFCGAL="1.3.0"
PROJ="Rel. 4.9.3, 15 August 2016" GDAL="GDAL 2.2.0, released 2017/04/28"

This leads me to believe that either something is wrong with my PROJ
configuration, as Paul suggested, or that something has been fundamentally
broken between proj4.8 and proj4.9. Should I be able to rely on the standard
Ubuntu 16.04 PROJ libraries? I've built 4.9.3 from source and also tried
using standard packages:

apt-get install libproj9 libproj-dev proj-data proj-bin

Both installations result in the same issue. Am I missing a critical
package, or is there environment variable that needs to be set for PROJ to
work properly with postgis?

Sent from: http://postgis.17.x6.nabble.com/PostGIS-User-f3516033.html

More information about the postgis-users mailing list