[postgis-users] Error: "Precision reduction requires GEOS-3.9 or higher"

Marco Boeringa marco at boeringa.demon.nl
Fri Apr 16 14:53:20 PDT 2021

Hi all,

I upgraded my Ubuntu 20.04 instance with "libgeos-3.9.0" from the 
ubuntugis repository.

When I use:

"SELECT PostGIS_Full_Version();"

I get back:

POSTGIS="3.1.1 aaf4c79" [EXTENSION] PGSQL="130" GEOS="3.9.0-CAPI-1.16.2" 
PROJ="6.3.1" LIBXML="2.9.10" LIBJSON="0.13.1" LIBPROTOBUF="1.3.3" 
WAGYU="0.5.0 (Internal)"

which at least suggests I am now correctly using GEOS 3.9.0 (note: I 
updated the PostGIS extension's functions using "ALTER EXTENSION postgis 

However, after adjusting some existing code to include the new 
"ST_ReducePrecision" PostGIS function 
(https://postgis.net/docs/ST_ReducePrecision.html), which is new in 
3.9.0, I get back an error:

"Precision reduction requires GEOS-3.9 or higher"

which seems weird given the "PostGIS_Full_Version" result. Anyone have a 
clue as to what I missed?


More information about the postgis-users mailing list