[postgis-users] Error: "Precision reduction requires GEOS-3.9 or higher"

Sandro Santilli strk at kbt.io
Sun Apr 18 12:18:48 PDT 2021

On Sun, Apr 18, 2021 at 02:42:14PM +0200, Marco Boeringa wrote:
> Hi Sandro,
> Thanks for the answer, but this just raises a question, why was the
> official PostGIS 3.1.1 as available in the
> "http://apt.postgresql.org/pub/repos/apt/focal-pgdg main"
> repository, not compiled with GEOS 3.9.0, if it is supposed to be able
> to take advantage of new GEOS 3.9.0 functionality?

You should ask the packagers. This is all a community
effort, and you can even make a difference by contributing
your time to do those builds yourself I think :)

> Or would a PostGIS 3.1.1 compiled against GEOS 3.9.0 cause issues on a
> default Ubuntu Focal install with just GEOS 3.8.0, due to
> incompatibilities?

To my knowledge GEOS upgrade never introduce incompatibilities,
unless there are packages that are using the C++ API of GEOS
(which we've campaigned enough to avoid)


More information about the postgis-users mailing list