[Qgis-developer] QGIS 0.9 on windows:QgsApplication.setPrefixPath() has an invalid type

Jesse Ayers jrayers at u.washington.edu
Sun Aug 5 18:57:56 EDT 2007

Unfortunately both Tisham's newly posted build, and the one linked to below
result in the same thing under PyQt4.3 and Qt4.3.  I tried uninstalling
PyQt4.3 and Qt4.3, then installing older versions (PyQt4.2 and Qt4.2.3) with
the same results under both of Tisham's recent builds and the one linked
below.  I tried an older version of PyQt (4.1.1) also with the same results.

I am open to suggestions on what to try next.

-----Original Message-----
From: Martin Dobias [mailto:wonder.sk at gmail.com] 
Sent: Sunday, August 05, 2007 10:10 AM
To: Jesse Ayers
Cc: Aaron Racicot; qgis-developer at lists.qgis.org
Subject: Re: [Qgis-developer] QGIS 0.9 on
windows:QgsApplication.setPrefixPath() has an invalid type

On 7/31/07, Jesse Ayers <jrayers at u.washington.edu> wrote:
> Here you go:
> >>> from qgis.core import *
> >>> str(QgsApplication.prefixPath())
> '<PyQt4.QtCore.QStringRef object at 0x00BA1DF8>'


you should get QString from QgsApplication.prefixPath() - so I'm quite
surprised what happens for you... I didn't have time so far to try
Tisham's build, but to make sure that the problem isn't in the build,
could you test whether this happens also with my (slightly older)
windows build?

Or maybe something went wrong in the latest (4.3) PyQt release...?


More information about the Qgis-developer mailing list