[Qgis-developer] QGIS 0.9 on windows:QgsApplication.setPrefixPath() has an invalid type

Martin Dobias wonder.sk at gmail.com
Sun Aug 5 20:36:27 EDT 2007

On 8/6/07, Jesse Ayers <jrayers at u.washington.edu> wrote:
> Unfortunately both Tisham's newly posted build, and the one linked to below
> result in the same thing under PyQt4.3 and Qt4.3.  I tried uninstalling
> PyQt4.3 and Qt4.3, then installing older versions (PyQt4.2 and Qt4.2.3) with
> the same results under both of Tisham's recent builds and the one linked
> below.  I tried an older version of PyQt (4.1.1) also with the same results.
> I am open to suggestions on what to try next.

I'm affraid that something's wrong with your Qt / PyQt. Regarding to
the Qt docs, QStringRef class has been introduced in Qt 4.3, thus it's
hard to believe that older versions of Qt and PyQt could have the same
behaviour. Please check whether the older versions (Qt4.2.x) are not
mixed with newer (qt4.3) somehow.

However, it should be possible to use string() or toString() member
functions of QStringRef classes that will return a QString.


More information about the Qgis-developer mailing list