[Qgis-developer] problem building qgis_core under windows 7

Nico Hardebol - CITG N.J.Hardebol at tudelft.nl
Fri Jun 15 03:11:23 PDT 2012

Dear Developers,

Another questions concerning the Quantum-GIS source. I briefly described the project that Martijn and I are on in regard to combining QGIS with 3D geometry (/CAD) functionality.

I have compiled many softwares under linux, although for QGIS I almost always simply use the binaries and never build under windows.
Yet, since our customized QGIS is a geological field acquisition tool that runs on a Windows Tablet PC, I need to compile under windows.

First I tried to simply build from the latest github src tree (as of last week) and carefully followed the instructions as provided by http://www.qgis.org/api/INSTALL.html#toc14

Tim Sutton already kindly pointed me to fact that QGIS should be built with Visual Studio (Express) v9 2008 and not with version 10, 2010 what I was using before.
As result, I no longer have the when building the qgis_core: "The system cannot find the batch label specified - VCReportError".

Instead,  I get the another error when building qgis_core that says: " ... Generating qgsexpressionparser.cpp ... The system cannot find the path specified.". I attached the corresponding BuildLog.htm file. Any idea what causes this new problem with building qgis_core?

I use a Windows 7 machine with Visual Studio 2008 (v9) and cmake(-gui) 2.8.8. Initially, I had various issues with the configure and generate in cmake-gui but, I think, I managed to resolve all of them. Except of one problem of which I am not sure if that may cause my issue with building QGIS to do with Windows SDK and the SetupAPI.Lib which I find on my system at C:/Progra~2/Microsoft SDKs/Windows/v6.0A/Lib/SetupAPI.Lib which I linked in cmake-gui configure.

Should I have and link /v7/Lib/SetupAPI.Lib instead during the cmake configure? The QGIS instructions say that "You also need the Microsoft Windows Server(r) 2003 R2 Platform SDK (for setupapi)". On my Windows 7 machine I instead downloaded the corresponding Windows SDK from http://www.microsoft.com/en-us/download/conf
The installation of  Windows SDK components through winsdk_web.exe gave the error problem as shown in WindowsSDK_installationError.txt

Could a v6.0A/Lib/SetupAPI.Lib be causing the problem with building qgis_core? Would an SDK for Windows 7 install a /v7/Lib/SetupAPI.Lib instead? How can I get a Windows 7 SetupAPI.Lib & Windows SDK installed on my system? All windows SDK installations give me the same error. A google search on Windows 7 SDK installation problem shows many reports and some suggestions. I tried several but none seem help. Anyone encountered this problem as well?

Any suggestions to resolve the issue with building qgis_core under Windows 7 are warmly welcomed!

Many thanks, Nico

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20120615/e3730c95/attachment-0001.html>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20120615/e3730c95/attachment-0001.htm>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: WindowsSDK_installationError.txt
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20120615/e3730c95/attachment-0001.txt>

More information about the Qgis-developer mailing list