[Qgis-developer] SAGA and TauDEM algs in QGIS from KingChaos package

Salvatore Larosa lrssvtml at gmail.com
Tue Nov 22 04:01:41 PST 2016

On Mon, Nov 21, 2016 at 3:25 AM, William Kyngesburye
<woklist at kyngchaos.com> wrote:
> On Nov 20, 2016, at 2:19 PM, Salvatore Larosa <lrssvtml at gmail.com> wrote:
>> On Sun, Nov 20, 2016 at 9:04 PM, Johan Van de Wauw
>> <johan.vandewauw at gmail.com> wrote:
>>> Can you check if you have the same error when using saga_cmd without
>>> using processing?
>> I also tried saga_cmd from shell with the following command:
>> saga_cmd io_gdal 0 -TRANSFORM 1 -INTERPOL 0 -GRIDS
>> "/Users/slarosa/MU/elevationutm.sgrd" -FILES
>> "/Users/slarosa/MU/elevation_utm.tif"
>> and it throws:
>> ...
>> 21:15:02: Error: Failed to get the working directory (error 2: No such
>> file or directory)
> I don't get a directory error, but it does say "Grids: No objects".
>> On Nov 20, 2016, at 2:04 PM, Johan Van de Wauw <johan.vandewauw at gmail.com> wrote:
>> @William: Which compiler was used for saga on mac os x? We had an
>> issue with gcc6 - this looks similar. It is fixed in trunk and in
>> (upcoming) 2.3.2 release of SAA.
> I'm using Clang 7.0.2 from Xcode 7.2.  Is the fix something that can be backported to 2.2?  QGIS doesn't support 2.3+ yet.

Just more info on this issue:
I just noticed that saga commands work correctly when the SRS layers
is not projected (i.e. epsg:4326).
Using UTM projection (i.e epsg:32633) on raster and vector layer SAGA
fails with segfault.

Thanks to take in account this issue.

Salvatore Larosa
linkedIn: http://linkedin.com/in/larosasalvatore
twitter: @lrssvt
skype: s.larosa
IRC: lrssvt on freenode

More information about the Qgis-developer mailing list