[QGIS-Developer] PostGIS 3D cube lacks vertical faces

G. Allegri giohappy at gmail.com
Wed Dec 20 02:06:48 PST 2017


I've just updated to the latest nightly build from osgeo4w on my Dell XPS13
with Windows 10 Home Edition.
The result is:

 - flat geometry inside 3d view
 - cannot zoom more then what can be seen in the following image

https://photos.app.goo.gl/NjiE12dN7ajY4ASr1

giovanni

2017-12-20 10:19 GMT+01:00 Anita Graser <anitagraser at gmx.at>:

> Hi Jakob,
>
> On Wed, Dec 20, 2017 at 9:26 AM, Jakob Lanstorp <jlanstorp at gmail.com>
> wrote:
>
>> Hi Anita et al,
>>
>> How did you get the geometry into QGIS. I have tried running a sql from
>> within the db manager plugin on a postgis datebase like:
>>
>> SELECT
>> 'POLYHEDRALSURFACE Z (
>>     ((0 0 0, 0 1 0, 1 1 0, 1 0 0, 0 0 0)),
>>     ((0 0 0, 0 1 0, 0 1 1, 0 0 1, 0 0 0)),
>>     ((0 0 0, 1 0 0, 1 0 1, 0 0 1, 0 0 0)),
>>     ((1 1 1, 1 0 1, 0 0 1, 0 1 1, 1 1 1)),
>>     ((1 1 1, 1 0 1, 1 0 0, 1 1 0, 1 1 1)),
>>     ((1 1 1, 1 1 0, 0 1 0, 0 1 1, 1 1 1))
>>   )'::geometry
>>
>> It show the polyhedral in 2D in both QGIS 2D and 3D window, but crashes
>> QGIS
>> when changing properties.
>>
>>
> ‚ÄčThe crashes are a general issue reported here: https://issues.qgis.org/
> issues/17416
>
> On some machines it crashes, on others it doesn't. If you find a
> non-crashing machine, you'll see the cube.
>
> Regards,
> Anita‚Äč
>
>
>
>
> _______________________________________________
> QGIS-Developer mailing list
> QGIS-Developer at lists.osgeo.org
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20171220/b5594fe3/attachment-0001.html>


More information about the QGIS-Developer mailing list