[QGIS-Developer] GDAL-OGR version

Yves Jacolin yjacolin at free.fr
Tue Jun 20 04:56:45 PDT 2017


On mardi 20 juin 2017 13:28:08 CEST Even Rouault wrote:
> On mardi 20 juin 2017 13:09:00 CEST Yves Jacolin wrote:
> > Hello,
> > 
> > I built QGIS with gdal-ogr version 2.2 but I get a crash with this
> > message:
> > symbol lookup error: /home/yjacolin/Documents/Developpement/
> > qgis_install_stable/lib/libqgis_core.so.2.18.9: undefined symbol:
> > OGR_F_IsFieldSetAndNotNull
> > 
> > Does QGIS 2.18.9 supports gdal 2.2?
> 
> Yves,
> 
> The fact that you get this error message is a proof that latest QGIS 2.18
> supports GDAL 2.2 ;-)
> 
> What likely happens here is that you have built QGIS against GDAL 2.2 header
> files, but at runtime an older libgdal is found. Check your PATH /
> LD_LIBRARY_PATH.
> 
Even, J├╝rgen,

Shame on me, I renamed the path to GDAL in the past and my QGIS script was not 
uptodate :/

Many thanks to both of you,

Y.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20170620/540e7ca5/attachment.sig>


More information about the QGIS-Developer mailing list