[QGIS-Developer] Qt Designer Cannot Drop Widgets onto QgsDockWidget

Denis Rouzaud denis.rouzaud at gmail.com
Tue May 23 23:51:32 PDT 2017

Hi Calvin,

I can reproduce.
This is very strange as the custom widget is indeed defined as a container,
so it should be able to receive widgets.
I tried on fedora + master, you tried on windows + 2.18, so it doesn't seem
to be OS or Qt version dependant.

Anyone else can confirm?


Le mar. 23 mai 2017 à 17:01, C Hamilton <adenaculture at gmail.com> a écrit :

> If I start with a QgsDockWidget in Qt Designer rather than a QDockWidget,
> I cannot add another widget to it. With QDockWidget I have a QWidget inside
> and then all of the other components. I simply cannot add anything to
> QgsDockWidget. Is anyone else having the same problem?
> I am using the latest version (2.18.8) shipped with the OSGeo4W installer
> on Windows 7.
> Thanks,
> Calvin
> _______________________________________________
> QGIS-Developer mailing list
> QGIS-Developer at lists.osgeo.org
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20170524/3489e74f/attachment.html>

More information about the QGIS-Developer mailing list