[QGIS-Developer] QGIS builds

Rudi von Staden rudivs at gmail.com
Fri Aug 10 07:22:02 PDT 2018

On Wed, 8 Aug 2018 at 23:47, Nyall Dawson <nyall.dawson at gmail.com> wrote:

> > I have the build environment set up from scratch on a new computer, and
> I'm getting the same error building mdalprovider in the master branch
> (C:\OSGeo4W64\bin\hdf5.dll : fatal error LNK1107: invalid or corrupt file:
> cannot read at 0x2F0).
> I've seen this too. I haven't had time to investigate a proper fix, so
> in the meantime I just edit src/providers/mdal/CMakeLists.txt and
> remove all mention of HDF5. That gets the build working temporarily.

Thanks, that worked. I also encountered an issue with `synccrsdb` (MSB6006
cmd.exe exited with code -1073741515). In case anyone else comes across
that, the solution was to copy crssync.exe from 'OSGeo4W64\apps\qgis-dev'
to 'C:\OSGeo4W64\bin'. It's probably in one of the other osgeo4w packages,
but I haven't figured out which one yet.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20180810/8c7844fb/attachment.html>

More information about the QGIS-Developer mailing list