[QGIS-Developer] QGIS builds

Nyall Dawson nyall.dawson at gmail.com
Wed Aug 8 14:47:37 PDT 2018

On Thu, 9 Aug 2018 at 07:23, Rudi von Staden <rudivs at gmail.com> wrote:
> I have the build environment set up from scratch on a new computer, and I'm getting the same error building mdalprovider in the master branch (C:\OSGeo4W64\bin\hdf5.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x2F0). Is there maybe a problem with hdf5.dll from osgeo4w? I've tried downloading the source from https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-1.8.11/src/ and building it, but even then I run into "CPack Error: Error when generating package: HDF5".
> Has nobody else had any issues with hdf5.dll? Are the instructions for 4.1 at https://github.com/qgis/QGIS/blob/master/INSTALL still accurate?

I've seen this too. I haven't had time to investigate a proper fix, so
in the meantime I just edit src/providers/mdal/CMakeLists.txt and
remove all mention of HDF5. That gets the build working temporarily.


> Kind regards,
> Rudi
> On Thu, 26 Jul 2018 at 10:34, Rudi von Staden <rudivs at gmail.com> wrote:
>> Hi all,
>> I'm trying to build qgis from source, but I'm getting a linking error in `mdalprovider`:
>> C:\OSGeo4W64\bin\hdf5.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x2F0
>> I have successfully built qgis before, so any idea why this would be causing a problem now?
>> As background, I'm trying to build a particular pull request to help with testing. The steps I took were:
>> 1. git fetch origin pull/7396/head:rastercalc
>> 2. git checkout rastercalc
>> 3. delete directory build-qgis-test-x86_64 (in QGIS/ms-windows/osgeo4w)
>> 4. run configonly.bat
>> 5. run OSGeo4W-dev.bat (which executes `call C:\Users\rudi_000\Source\Repos\QGIS\ms-windows\osgeo4w\msvc-env.bat x86_64`)
>> 6. run devenv from command prompt
>> 7. open qgis.sln
>> 8. build
>> I have tried cleaning and rebuilding mdalprovider, but get the same result. It could be that just repeating the process described above would resolve the issue (from point 3.), but since it takes several hours to build (I'm building on a pretty old laptop) I thought I'd ask in case I'm doing something wrong in the process.
>> Thanks,
>> Rudi
> _______________________________________________
> QGIS-Developer mailing list
> QGIS-Developer at lists.osgeo.org
> List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
> Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

More information about the QGIS-Developer mailing list