[QGIS-it-user] Matplotlib

Benedetta Basso benedetta01 a hotmail.it
Mar 23 Mar 2021 11:32:37 PDT


Ciao Ivano, 
Allora se inserisco $ pip3 -V su terminale mi appare quanto segue: pip 20.2.3 from /Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/pip (python 3.9). 
Mentre se digito 'sudo easy_install pip’ mi richiede la password che non riesco in nessun modo a inserire.
Grazie ancora,
Benedetta
> Il giorno 23 mar 2021, alle ore 19:00, Ivano Giuliano <ivano.giuliano a gmail.com> ha scritto:
> 
> Ciao Benedetta,
> occorrerebbe conoscere in modo pi¨ approfondito le informazioni riguardanti l'installazione effettuata, per poter circoscrivere il problema.
> Ad ogni modo, puoi controllare la versione di PIP che stai utilizzando, digitando da Terminale :
> 
> $ pip -V
> 
> Fatto questo, necessita  capire a quale versione di Python,il tuo gestore  PIP Ŕ associato, in quanto occorre installare la versione corrispondente alla rispettiva versione di Python che QGIS utilizza per il suo funzionamento.Tutte le librerie verrebbero installate di conseguenza, in modo corretto,  in quanto riconosciute come dipendenze valide.
> Potresti ricorrere a :
> 
>   $ sudo easy_install pip  
>   $ sudo pip install --upgrade pip  
> 
> per reinstallare PIP o AGGIORNARLO.
> 
> Potresti inoltre non aver installato SETUPTOOLS o averlo installato in modo non corretto, oppure ancora, necessita di essere aggiornato : 
> 
> $pip install --upgrade setuptools
> 
> E infine, potresti provare con il reinstallare la libreria matplotlib :
> 
> $ pip install matplotlib
> $ pip3 install matplotlib
> 
> Un saluto
> 
> 
> Ivano
> 
> 
> 
> 
> _______________________________________________________________
> 
>                                       dott. Ivano GIULIANO
> Pianificatore Territoriale/Ambientale - Piattaforme Telematiche PA
>          Sistemi Informativi Geografici - GIS - Aerofotogrammetria
> 
> The information contained in this e-mail message is confidential and intended only for the use of the individual or entity named above. If you are not the intended recipient, please notify us immediately by telephone or e-mail and destroy this communication. Due to the way of the transmission, we do not undertake any liability with respect to the secrecy and confidentiality of the information contained in this e-mail message.
> 
> 
> 
> 
> Il giorno mar 23 mar 2021 alle ore 16:01 Benedetta Basso <benedetta01 a hotmail.it <mailto:benedetta01 a hotmail.it>> ha scritto:
> Ciao a tutti,
> Dopo aver risolto il problema precedente con GDAL ne ho, purtroppo, riscontrato un altro che pensavo di aver superato. Il problema è dovuto all’utilizzo del plugin Semi-Automatic Classification e alla visualizzazione delle firme spettrali attraverso la libreria python Matplotlib. Dopo aver installato quest’ultima su terminale attraverso il pip di python, QGIS continua a visualizzarmi l’errore di non riconoscimento del ‘pacchetto’ suddetto. Sapete come posso risolvere?
> Grazie a tutti per la disponibilitÓ e buona giornata.
> Benedetta
> _______________________________________________
> QGIS-it-user mailing list
> QGIS-it-user a lists.osgeo.org <mailto:QGIS-it-user a lists.osgeo.org>
> https://lists.osgeo.org/mailman/listinfo/qgis-it-user <https://lists.osgeo.org/mailman/listinfo/qgis-it-user>

-------------- parte successiva --------------
Un allegato HTML Ŕ stato rimosso...
URL: <http://lists.osgeo.org/pipermail/qgis-it-user/attachments/20210323/7ea1eab3/attachment.html>


Maggiori informazioni sulla lista QGIS-it-user