[GeoNode-devel] Custom geonode project installation

Toni Schönbuchner toni.schoenbuchner at csgis.de
Wed Jan 2 09:43:21 PST 2019

Hi Dimitris,

let me recap:

> IOError: [Errno 13] Permission denied: '/usr/local/share/GeoIP'

This was solved by settings permissions of /usr/local/share

> And then when I run the paver sync or the paver start (as in the instructions), I get:
> "...
> django.db.utils.OperationalError: could not connect to server: Connection refused
>     Is the server running on host "localhost" ( and accepting
>     TCP/IP connections on port 5432?

Note, with dev setup there is neither tomcat nor postgresql involved.
GeoServer is run by use of Jetty. Instead of Postgresql Setup we´re using

So the error is here:
You´re using local_settings which expects a running postgresql server.

(settings instead of local_settings) instead.

> I am running the installation in a virtual environment inside a vagrant VM (ubuntu/xenial64). I thought it could be related with the port forwarding but that seems to be configured ok in the vagrantfile:
>   config.vm.network :forwarded_port, guest: 5432, host: 5432

This is totally fine. It would only matter when running in production.
(Sqlite should not care about the port, in production I would further close 5432 and
only connect by local_tunnel to postgres)

> I also tried to check the configuration in the pg_config file but I can not find out where my postgres is installed. I run: which psql but there is no output. 

Also only relevant with production setup. ;)

> On a different note, the installation comes with jetty server right?

See above.

As summary. You can use the dev setup with with django-dev-server, jetty and sqlite to quickly
setup a environment for development. Going to production is much more complex as the different
parts have to be configured. ( The docs explain how (a bit outdated but working.) I´ve created a little
ansible playbook which automates those steps: https://github.com/csgis/geonode_ansible <https://github.com/csgis/geonode_ansible> )

Hope this helps,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20190102/a7ed0dba/attachment.html>

More information about the geonode-devel mailing list