[GeoNode-devel] Problems Running GeoNode's Test Suite

Travis Brundage travislbrundage at gmail.com
Wed Nov 6 23:00:00 PST 2019

Just following up on this, I realized the tests were stopping because I was
passing the --failfast option when running them.

Still, this error affects the overwhelming majority of GeoNode's unit tests
for me, so it's a blocker for me for running them. Changing the celery and
django-celery-beat versions did not have any affect.

Has anyone else seen this error or am I doing something wrong? Perhaps
there is a config option for celery I need to set?

On Thu, Oct 31, 2019 at 12:13 PM Travis Brundage <travislbrundage at gmail.com>

> Hey all,
> So I have been struggling a bit with figuring out how to run GeoNode's
> test suite properly, and I've also run into multiple problems. I am still
> not entirely clear on what I am supposed to be doing to run GeoNode's
> tests, but here is what I have done:
> In .env: SET_DOCKER_ENV=development
> Starting GeoNode docker: docker-compose -f docker-compose.async.yml -f
> docker-compose.development.yml up -d
> Configuring the system for running tests:
> 1. Install python 2.7 on the system. Checking python version is 2.7.x:
> python --version
> 2. Create a python virtual environment for GeoNode dev
> 2a. Install virtualenv: sudo apt-get install python-virtualenv
> 2b. Create Python2.7 virutalenv: virtualenv -p `which python2.7`
> geonode-env
> 2c. Activate the environment: source geonode-env/bin/activate
> 3. In geonode/ install the requirements: pip install -r requirements.txt
> 4. Configure GDAL bindings (reference
> https://mothergeo-py.readthedocs.io/en/latest/development/how-to/gdal-ubuntu-pkg.html
> ):
>     sudo add-apt-repository ppa:ubuntugis/ppa && sudo apt-get update
>     sudo apt-get update
>     sudo apt-get install gdal-bin
>     sudo apt-get install libgdal-dev
>     export CPLUS_INCLUDE_PATH=/usr/include/gdal
>     export C_INCLUDE_PATH=/usr/include/gdal
>     pip install GDAL==2.4.2
> Finally, running tests: coverage run --branch --source=geonode manage.py
> test <geonode.app.tests> --noinput
> (replacing with app I want to test)
> Btw, I added this to our running document of notes for GeoNode, but please
> point out if I am doing something incorrectly:
> https://docs.google.com/document/d/1h4xhXTejSkfqmEQmzl6CkcySc9_COZldm_5qvFI3fB8/
> For a while this was mostly working (just slow, some problems in the setUp
> causing that). However, now I have run into a blocking issue. I don't know
> what I have done or changed other than pulling recent commits. Celery is
> complaining about an improperly configured file-system backend.
>     ImproperlyConfigured: The configured path for the file-system backend
> does not work correctly, please make sure that it exists and has the
> correct permissions.
> Full stack trace:
> https://gist.github.com/travislbrundage/81fe15cf06c5179e9b8cf16060f98d5c
> Every test I run has the same result. Anyone have pointers for what this
> might mean is wrong with my GeoNode?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20191106/3164abc0/attachment.html>

More information about the geonode-devel mailing list