[GeoNode-users] New Install error - no module

Handy Rusydi handy at galerigis.com
Sun Oct 27 16:14:05 PDT 2019

So do I. I have same issue as you
Sent from myMail for Android Senin, 28 Oktober 2019, 06:11AM +07:00 from Narelle Irvine  narelle.irvine at gmail.com :

>I have tried installing Geonode Core on a new 8GB computer running Ubuntu 18.04.3
>I have the Geoserver working (localhost:8080/geoserver, but not Geonode (localhost:8080). Error is unable to connect.
>When I get to the command
> python manage.py collectstatic --no-input
> the response is
>        ImportError: No module named osgeo
>I have also seen errors saying 
>  ImportError: No module named geonode.settings
>Is this related to environment variables? I think I had some issues with which user (nirvine or geonode) and the virtualenv as I was working through the instructions, but I have tried so many things in the last couple of days that I no longer know what is happening. 
>I am in the geonode virtual env, and the settings are: 
>LESSCLOSE=/usr/bin/lesspipe %s %s
>SSH_CLIENT= 49504 22
>PS1=(geonode) \[\e]0;\u@\h: \w\a\]${debian_chroot:+($debian_chroot)}\u@\h:\w\$
>LESSOPEN=| /usr/bin/lesspipe %s
>Assistance, please?
>Narelle Irvine
>Ph. 0413592876
>geonode-users mailing list
>geonode-users at lists.osgeo.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20191028/d9094ac1/attachment.html>

More information about the geonode-users mailing list