[postgis-users] WKT raster installation on Mac Snow Leopard

Javier de la Torre jatorre at vizzuality.com
Tue Jul 20 12:11:01 PDT 2010


I make use of the Kyngchaos builds for Postgis in Mac OS X Snow Leopard (10.6.4). I am trying to install the WKT raster on my existing PostGIS but I havent succeed. 

I have tried downloading the same version of PostGIS code that I have installed via Kyngchaos and use it to compile WKT raster. I had to copy config.sub and config.guess because it was complaining and then I ran:

./configure --with-postgis-sources=/Users/jatorre/workspace/postgis-1.5.1/ --with-pgconfig=/usr/local/pgsql/bin/pg_config --with-gdal=/Library/Frameworks/GDAL.framework/unix/bin/gdal-config --with-geos=/Library/Frameworks/GEOS.framework/unix/bin/geos-config

But the error I get is:

ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
ld: warning: directory '/Users/Shared/unix/gettext-snow/lib' following -L not found
lipo: can't open input file: /var/folders/9N/9NtAH8bAEhe6+LEqwLi43E+++TI/-Tmp-//cc15Lk7k.out (No such file or directory)
make[1]: *** [rtpostgis.so] Error 1
make: *** [pglib] Error 2

If I try to compile postgis I get the same error.

I took a look at how the sources from kyngchaos were created (http://www.kyngchaos.com/macosx/build/postgis) but they are not up to date with Snow Leopard.

Anybody has succeed previously?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20100720/5ec2ce93/attachment.html>

More information about the postgis-users mailing list